Author Topic: Ground friction in FSX  (Read 17170 times)

Dieter

  • Sr. Member
  • ****
  • Posts: 792
    • View Profile
Ground friction in FSX
« on: January 14, 2013, 03:30:38 PM »
I really wonder, never read anything about this very interesting article here in our forum:
http://forum.avsim.net/topic/392772-inhere...round-friction/

There are many postings meanwhile but worthwhile to read, going into depth of FSX and offering deep and specialised knowledge to this theme.

If you don't like to read the many pages or this stuff is too theoretically
here is a short instruction, what to do:

Download latest FSUIPC
http://forum.simflight.com/topic/66139-updated-modules/
- FSUIPC4859n.zip

Download latest LUA here:
http://forum.simflight.com/topic/68257-lat...and-wideclient/

Lua Plugins Package (old posting but latest LUA)
- Lua_Plugins_10Dec.zip


FSUIPC not registered:
copy file “Frictions.lua" in \FSX\Modules
In "FSUIPC4.ini" enter under [General]:
PatchSIM1friction=Yes

- Save "FSUIPC4.ini"

FSUIPC registered:
Copy file "DynamicFriction.lua" in FSX\Modules
In "FSUIPC4.ini" enter:
[Auto]
1=Lua DynamicFriction

- Save "FSUIPC4.ini"

Dieter
Many greetings
Dieter

Dragnhorn

  • Sr. Member
  • ****
  • Posts: 742
  • "Ahhhhh..the smell of black powder in the morning"
    • View Profile
Re: Ground friction in FSX
« Reply #1 on: January 15, 2013, 02:33:28 AM »
Great find Dieter!  I stopped reading at 10 pages of comments but it's good to read Pete's writings again.  I was a beta tester for Radar Contact for a long time and got to know Pete a bit.   I've downloaded the newest FSUIPC and the LUA files, changed the .ini and will go test.

Thanks
Rob Abernathy
aka Dragnhorn

PC specs: 
Intel Quad Core i7 4790k Devil's Canyon (Haswell), 4.0 GHZ, /Gigabyte 87 UD4H 32 GB mother board, 16 GB DDR3 1866MHZ, Nvidia GTX 760 2 GB x 2 SLI, 2 TB 7200RPM HDD, Cpu Liquid Cooling Unit LVL 4, 750W Thermaltake, Windows 7 64 bit

spud

  • Misty Moorings Team
  • Hero Member
  • *
  • Posts: 3,082
    • View Profile
Re: Ground friction in FSX
« Reply #2 on: January 15, 2013, 03:16:30 PM »
Dieter,
not quite sure what to do.  When you say:

"FSUIPC not registered:
copy file “Frictions.lua" in \FSX\Modules
In "FSUIPC4.ini" enter under [General]:
PatchSIM1friction=Yes

- Save "FSUIPC4.ini"

At the  moment I have the Frictions.lua file in the FSX\Modules folder.  Should it be placed inside the FSUIPC4.ini file?  And the 'PatchSIM1friction=yes' added to the [General] section of the .ini file as well.  I have the latter added to the .ini file but am not sure about exactly where the Frictions.lua file should be.
 8)
Later,

Spud

Dieter

  • Sr. Member
  • ****
  • Posts: 792
    • View Profile
Re: Ground friction in FSX
« Reply #3 on: January 15, 2013, 05:59:23 PM »
Spud,
you did it correct.

In "Lua_Plugins_10Dec.zip" you find a file "Example LUA plugins.zip"
When unzipped, only copy the file "Frictions.lua" in your \FSX\Modules folder.

Now open FSUIPC4.ini (with any editor), at the end of the section [General] you enter
PatchSIM1friction=Yes

Now save the  FSUIPC4.ini and you are done.

Run FSX

Dieter
Many greetings
Dieter

spud

  • Misty Moorings Team
  • Hero Member
  • *
  • Posts: 3,082
    • View Profile
Re: Ground friction in FSX
« Reply #4 on: January 15, 2013, 10:11:45 PM »
Thanks Dieter,
that is what I had done but was not sure it was correct.  I do know that at least with some A/C I have side slip when turning while taxiing.  Before this "fix" I did not have it as bad.  Go Figure!
 8)
Later,

Spud

BonGood

  • New Member
  • *
  • Posts: 1
    • View Profile
Re: Ground friction in FSX
« Reply #5 on: January 20, 2017, 02:14:10 AM »
Thanks Dieter,
that is what I had done but was not sure it was correct.  I do know that the https://www.grosseteste.com/bathmate-x20-review-results old Bathmate X20 at least with some A/C I have side slip when turning while taxiing.  Before this "fix" I did not have it as bad.  Go Figure!
 8)

I just downloaded and I can't wait to get started. Thanks Dieter.
« Last Edit: August 30, 2017, 10:47:58 AM by BonGood »

spud

  • Misty Moorings Team
  • Hero Member
  • *
  • Posts: 3,082
    • View Profile
Re: Ground friction in FSX
« Reply #6 on: January 20, 2017, 12:31:10 PM »
BonGood,
you do realize that this post is 4 years old and I would be cautious making alterations to your sim on advice that old.  Plus FSUICP had gone through many version since that time.
At this time FSUIPC is at version 4.959 and the info in this thread is most likely outdated.  I would download and install the latest FSUIPC rather than follow information so old.

http://www.schiratti.com/dowson.html

Later,

Spud

Dieter

  • Sr. Member
  • ****
  • Posts: 792
    • View Profile
Re: Ground friction in FSX
« Reply #7 on: January 20, 2017, 01:34:29 PM »
All informations given above are still valid and applicable.
- Of course FSUICP should be upgraded to latest version.

Additionally I recommend to assign a key command to "Brakes anti-skid ON/OFF" in the Controls menu.(although small GA planes are normally not equipped with this system)
This system must be activated again each time when the sim has been started or when the aircraft was changed.
Just give it a try.
Many greetings
Dieter

jsapair

  • Hero Member
  • *****
  • Posts: 1,173
  • Don't follow me, I'm lost.
    • View Profile
Re: Ground friction in FSX
« Reply #8 on: January 20, 2017, 07:17:43 PM »
Good eye, Spud. When I first saw the post I thought, "wow, Dieter got 12,000 reads? Must be a typo or a real hot topic. Haha. Didn't catch the date. Ah, so.

jsapair
Jsapair

Dieter

  • Sr. Member
  • ****
  • Posts: 792
    • View Profile
Re: Ground friction in FSX
« Reply #9 on: July 15, 2018, 10:53:21 AM »
In P3D open tab
Option-Controls-Key Assignments
Search for: "Brakes anti-skid (on/off)" and design a key for this (press new).
Most of the keys are already taken, so you might choose 2 keys
- CTRL and (your choice)
Many greetings
Dieter

Dieter

  • Sr. Member
  • ****
  • Posts: 792
    • View Profile
Re: Ground friction in FSX
« Reply #10 on: July 20, 2018, 10:47:13 AM »
For installing in FSX please start to read my 1. posting und following  in this thread.
Many greetings
Dieter

TylerManley

  • New Member
  • *
  • Posts: 1
    • View Profile
Re: Ground friction in FSX
« Reply #11 on: October 10, 2018, 03:51:38 PM »
All informations given above are still valid and applicable.
- Of course FSUICP should be upgraded to latest version.

Additionally I recommend to assign a key command to "Brakes anti-skid ON/OFF" in the Controls menu.(although small GA planes are normally not equipped with this system)
This system must be activated again each time when the sim has been started or when the aircraft was changed.
Just give it a try.

Hey
how to dole out a key order to "Brakes hostile to slide ON/OFF" in the Controls menu? I'm by one means or another neglecting to do as such.

jeff3163

  • Misty Moorings Team
  • Hero Member
  • *
  • Posts: 3,414
  • Troubleshooting & Help
    • View Profile
Re: Ground friction in FSX
« Reply #12 on: October 10, 2018, 07:43:03 PM »
In P3D open tab
Option-Controls-Key Assignments
Search for: "Brakes anti-skid (on/off)" and design a key for this (press new).
Most of the keys are already taken, so you might choose 2 keys
- CTRL and (your choice)

Hello JenniferTolley and TylerManley,
     These are the instructions for setting the key assignment to "Brakes anti-skid(on/off)" in your simulators controls setup pages. 

(thanks Dieter)  ;)
« Last Edit: October 10, 2018, 07:46:25 PM by jeff3163 »

Win10Pro64, P3Dv4.3.29.25520, AMD Ryzen7 1800X@3.6 GHz , 32Gb RAM, NVidia GTX 1080 Ti, 1T/1T SSD's for Sims/OS, 3x42" Vizio Monitors, HTC Vive VR HMD, Saitek Yoke/Pedals/trim wheel, XBox360 Controller, G27 steering wheel w/shifter+pedals. :P

donaldh

  • New Member
  • *
  • Posts: 1
    • View Profile
Re: Ground friction in FSX
« Reply #13 on: October 12, 2018, 07:59:12 AM »
All informations given above are still valid and applicable.
- Of course FSUICP should be upgraded to latest version.

Additionally I recommend to assign a key command to "Brakes anti-skid ON/OFF" in the Controls menu.(although phenq being reviewed here explain many things small GA planes are normally not equipped with this system)
This system must be activated again each time when the sim has been started or when the aircraft was changed.
Just give it a try.

After upgrading FSUICP to the latest version, how to assign a key command to "Brakes anti-skid ON/OFF" in the Controls menu? I'm somehow failing to do so.

I'm also getting the same problem but will check out the controls setup pages. I hope this will solve the issue.

Dieter

  • Sr. Member
  • ****
  • Posts: 792
    • View Profile
Re: Ground friction in FSX
« Reply #14 on: October 13, 2018, 04:12:00 AM »
This article might help:
https://www.a2asimulations.com/forum/viewtopic.php?f=23&t=49537

Information:
After changing to another aircraft, the anti-skid function must be switched on again. (chosen key press for anti-skid must be done again)

Many greetings
Dieter